Letzte Aktivitäten

  • Benutzer-Avatarbild

    Neo_miner -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    Ok gut vielen dank an dich @Multivitamin
  • Benutzer-Avatarbild

    Multivitamin -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    Nur beim Proxy reicht
  • Benutzer-Avatarbild

    Neo_miner -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    ok gut komischer weise hat es jetzt funktioniert, eine frage hätte ich noch muss ich beim sinusbot die ssl verschlüsselung jetzt auch aktivieren oder reicht die reversed proxy ?
  • Benutzer-Avatarbild

    Sebbo -

    Mag den Beitrag von Multivitamin im Thema Sinusbot mit https.

    Like (Beitrag)
    Du musst die Sub Domain auf die Richtige IP Routen und dann wenn du sowieso kein Webserver hast über --standalone ein cert bei letsencrypt anfordern Wenn deine Subdomain "nicht geht" wird das warscheinlich auch nichts
  • Benutzer-Avatarbild

    Sebbo -

    Mag den Beitrag von Multivitamin im Thema Sinusbot mit https.

    Like (Beitrag)
    Am besten über einen Apache/NGINX Reverse Proxy, Anleitungen gibts hier: Reverse Proxy [SinusBot Wiki]
  • Benutzer-Avatarbild

    Neo_miner -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    wenn ich probiere den bot so aufzurufen, komme ich zwar auf das webinterface, aber warum geht die reverse proxy von nginx nicht ? Quellcode (10 Zeilen)
  • Benutzer-Avatarbild

    Neo_miner -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    den webserver habe ich gerade testweise gestoppt und der bot läuft auf 8080
  • Benutzer-Avatarbild

    Multivitamin -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    Nginx hat in dem Sinn keine vHosts ist 173.239.0.52 denn die richtige IP? Weil da läuft bei dir kein WebServer auf Port 80 bzw kein Sinusbot auf Port 8087 EDIT: Quellcode (1 Zeile) darüber kannst du ja deinen Bot erreichen
  • Benutzer-Avatarbild

    Neo_miner -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    Die normale website geht ja auch, ist auch ein vhost für die bot.mcnoobs.pro subdomain angelegt, aber die domain funktioniert trotzdem nicht
  • Benutzer-Avatarbild

    Multivitamin -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    Wenn du den als Webserver installiert hast und der läuft + konfiguriert dafür ist sowie die dazugehörigen Ports freigeben sind
  • Benutzer-Avatarbild

    Neo_miner -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    aber nginx müsste dafür ja einspringen oder ?
  • Benutzer-Avatarbild

    Multivitamin -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    Blos weil du ein A Record hast heisst das noch lange nicht dass du da eine Gegenstelle hast die reagiert, vor allem fehlt dir der Sinusbot Port am ende
  • Benutzer-Avatarbild

    Neo_miner -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    Habe ich,dann kommt aber Diese Website ist nicht erreichbar bot.mcnoobs.pro hat die Verbindung abgelehnt. bilder-upload.eu/show.php?file=00320a-1513259877.png picload.org | dns.png
  • Benutzer-Avatarbild

    Multivitamin -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    du erstellst einen neuen A Record auf die gewünschte IP bei deinem Anbieter bei dem du die IP gemietet hast
  • Benutzer-Avatarbild

    Neo_miner -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    ich meinte mit der subdomain, da ich nicht verstehe wieso sie nicht funktioniert
  • Benutzer-Avatarbild

    Multivitamin -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    Bin ich doch gerade dabei
  • Benutzer-Avatarbild

    Neo_miner -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    @Multivitamin wärst du bereit mir dabei zu helfen ?
  • Benutzer-Avatarbild

    Multivitamin -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    Du musst die Sub Domain auf die Richtige IP Routen und dann wenn du sowieso kein Webserver hast über --standalone ein cert bei letsencrypt anfordern Wenn deine Subdomain "nicht geht" wird das warscheinlich auch nichts
  • Benutzer-Avatarbild

    Neo_miner -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    Aber wie beantrage ich das Zertifikat mit certbot ? Da aus irgend einem grund meine subdomain nicht funktioniert
  • Benutzer-Avatarbild

    Multivitamin -

    Hat eine Antwort im Thema Sinusbot mit https verfasst.

    Beitrag
    Theoretisch warscheinlich schon in dem du die Pfade der Cert Files in der config.ini angibst