Anzeige von Paketverlust ab ca. 60 User!

  • Hallo,


    mir ist aufgefallen das seit neusten auf mein TS Server Paketverlust angezeigt wird wenn es mehr als 50 - 60 User werden..


    Screenshots:


    Sprechen kann man aber ohne Probleme.
    Der Server hat eine Anbindung von 100 Mbit/s laut OVH!
    Welche auch eingehalten werden!


    Speedtest:




    Überlastet ist der Server meiner meinung auch nicht:


    Sobald es wieder unter ca. 50 User geht ist der angebliche Paketverlust weg!



    Nun weiß ich nicht wo der Fehler liegt.. :/
    Der Server hatte teils auch schon über 110 leute Online und da war kein Paketverlust!
    vil. hat jemand ja eine idee! :)
    mfg Paul

  • Fangen wir mal ganz von vorne an.
    Sicherlich ist es interessant wie viele User sich bei einer Lastspitze in einem Channel aufhalten da die Last für die Applikation dahingehend sinkt / steigt. Allerdings und das ist meiner Meinung nach der Punkt hier ich vermute der Screenshot von deinem htop zeigt eine eher ruhige Phase.


    Bei System wo timing interessant ist, also Games oder eben Voice ist der load interessant. Auf deinem Screenshot ist ein 15 Sekunden Load von 1.05 ein 1 Min Load von 1.18 und 5 Min Load von 1,24 zu sehen. Dabei hast du bloß 2 Threads. Heißt im Klartext wenn der Load größer als 2 ist muss ein Thread gleichzeitig mehr als 1 Aufgabe bearbeiten. Das führt dazu das Latenzen entstehen dadurch das ein gewisser Queue entsteht bei der Abarbeitung von Aufgaben. Versuch den Load auf deinem System niedrig zu halten. Dinge wie globale Verschlüsselung aus wenn du keine aes flag auf dem CPU hast und so weiter und sofort.


    Die Ruhebelastung von einem System sollte niemals mehr als 20% der Grundleistung fressen um Peaks auszugleichen usw. Falls sie es tut muss ein größeres System her oder eben eine Reduzierung der Systemdienste.

  • Wie ist die Userverteilung?
    Wie viele User sind dabei im gleichen Channel?
    Paketverlust vom Server zu bestimmten Clients oder zu allen?


    Die Daten müssen ja immer an alle User in dem Channel übertragen werden.


    1. Auf ca. 160 Channel
    2. Zwischen 1 und 6;7 User
    3. Zu allen Clients


    @mightyBroccoli ok hab mal soweit alles beendet was nicht wichtig ist und habe nun eine Load average von 0.260.530.70 bei 95 User.


    Zusetzlich hab ich mal ein Musikbot welcher auf dem Server läuft auf andere TeamSpeak Server aus der Server Liste connecten lassen und da hat er auch Paketverlust.
    Könnte es am Hoster liegen?

  • Guten Tag!


    Zitat | @mightyBroccoli

    Zitat

    Sicherlich ist es interessant wie viele User sich bei einer Lastspitze in einem Channel aufhalten da die Last für die Applikation dahingehend sinkt / steigt.


    Damit hast du Recht! Daher ist dieser Abteil schonmal
    #sinnvoll


    Zitat

    Bei System wo timing interessant ist, also Games oder eben Voice ist der load interessant.


    Ebenfalls richtig! :)

    Mit freundlichem Gruß,
    Justin vom Support [TScon is life]


    // Edit by Sebbo: Unnötige Kommentare entfernt.

    Mit freundlichem Gruß

    Justin Varox | TSCon Moderation


    Fragen? Bitte sende eine PM an mich!

    :!:Bitte halte dich an alle Regeln! Ich sehe alles :!:

  • Hallo,
    nur, um das nochmal kurz zu erwähnen, da das viele Leser nicht wissen: Die "Server Verbindungsinformationen" (3. Screenshot) zeigen immer den Durchschnitt aller Clients auf dem Server an. Hat also einer einen höheren Ping, treibt dieser den durchschnittlichen Ping in den Server Verbindungsinformationen in die Höhe.


    Warum einzelne Clients Paketverluste haben, kann mehrere Gründe haben:

    • Auslastung des Servers (Betriebssystem / Hardware)
    • Eine Firewall, die zu viel oder nicht gewünschten Traffic wegfiltert
    • (irgendeine genutzte) Leitung zwischen Server und Client
    • Auslastung des Clients (wenn ich z.B. etwas up- oder downloade, erhöht sich bei mir auf jedem TS3 Server prinzipiell immer der Ping und Paketverlust)

    Das der ein oder andere Client mal einen Paketverlust hat, ist mehr oder weniger normal und ok, denn man kann nicht bei allen dafür sorgen, dass sie perfekt angebunden sind. Hat jedoch jeder einen relativ gleichen Paketverlust, kann man schon eher ein serverseitiges Problem vermuten.


    Ich habe letztens nur mitbekommen, dass OVH mal wieder massive Netzwerkprobleme hat(te), was sich unter anderem durch Verbindungsabbrüche und Paketverluste bemerkbar machte.