TS3 Server Geteilt aber nur 1 Server erreichbar

  • Moin Leute

    Hoffe hier kann mir geholfen werden und zwar folgendes Problem.


    Ich hab ein TS3 Server auf ein VHost Server liegen der funzt auch und ist erreichbar.
    Nun habe ich den Server Geteilt damit mein Tochter nicht immer bei mir mit rauf muss um mit ihren Freunden zu reden.

    Das Problem ist der 2. Server ist nicht erreichbar
    Ich habe eine NPL für 512 Slots

    Hab also Server A 490 Slot zu gewiesen und Server B 22
    Auf Server A kann ich ohne Probleme zugreifen nur Server B mit dem anderen Port will sich nicht verbinden
    irgendwer eine Idee was man probieren könnte oder wodran es liegen kann?

    • Official Post

    Servus

    Mit so wenig Informationen ist es etwas schwierig, eine Aussage treffen zu können.


    Gehen wir es doch mal so an:

    1. Linux oder Windows vServer? Nur als Information für spätere Befehle, mögliche Ursachen etc.
    2. Laufen beide virtuelle TS3 Server? (Kannst du z.B. per ServerQuery Befehl, YaTQA, eines TS3 Administrationswebinterfaces wie z.B. Psychokiller's Webinterface prüfen)
    3. Sagen die Log-Dateien vom TS3 Server irgendwas? Die Instanz-Log (logs/*_0.log) und die jeweilige Log vom virtuellen Server (logs/*_<virtuelle_server_id>.log) sind hierbei wichtig.
    4. Wie lauten die jeweiligen Ports?
    5. Siehst du die beiden Ports aus 3. als "listening" im Betriebssystem? Wenn nicht, kann der TS3 Server nicht erreichbar sein. (siehe weiter unten im Beitrag)
    6. Hast du eine Firewall auf dem vServer? Wenn ja: Sind dort beide Ports freigegeben?
    7. Hast du eine Firewall vor dem vServer? Zum Beispiel eine Firewall vom vServer Anbieter? Wenn ja: Sind dort beide Ports freigegeben?
    8. Welchen Fehler erhält der Client beim verbinden?
    9. Welcher Fehler steht in der Log-Datei vom Client, nachdem Verbindungsversuch?

    Prüfen, ob die Ports entsprechend als "listening" im Betriebssystem gelistet sind:

    Code: Linux
    netstat -tulpen | grep <PORT-Nummer>
    
    # Beispiel:
    # netstat -tulpen | grep 9987
    Code: Windows
    netstat -anp UDP | findstr "<PORT-Nummer>"
    
    # Beispiel:
    # netstat -anp UDP | findstr "9987"
  • Hat sich erledigt
    Weiss nicht warum aber musste die Ports 2 X Freigeben in der Server Firewall


    Aber Danke für die Antwort und Hilfe